System Status
Inability to access the login page for MyWorkforce App
Incident Report for Compeat
Resolved
This incident has been resolved. Please have affected employees restart their MyWorkforce app to apply the fix.
Posted 29 days ago. Apr 22, 2019 - 13:22 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 29 days ago. Apr 22, 2019 - 13:14 CDT
Investigating
We are currently investigating this issue.
Posted 29 days ago. Apr 22, 2019 - 12:28 CDT
This incident affected: myWorkforce.