System Status
Phone System Maintenance
Incident Report for Compeat
Resolved
Maintenance concluded as of approximately 8:30 AM Central Time, and systems are working nominally.
Posted Jul 11, 2018 - 09:03 CDT
Identified
Maintenance is under way on the phone system in our corporate headquarters. Calls to our office may not complete while this maintenance is under way.
Posted Jul 11, 2018 - 08:11 CDT